Hello.
I’m going to throw the new firmware into the board … PROCEDURE: I plug the usb cable into the board and pc. Easily connect it under COM3. Then put the boot connector on the boot connector and press the reset button. The board disconnected from the PC and changed to AT90USB1286 (no COM3 port anymore). I’m going to add a new firmware, but there is a problem that I can not see in COM3 port … So I do not want to load a board after reset but without resetting and unplugging the boot connector it’s all, and in arduine it’s the COM3 port.
Did anyone meet this problem?
Thank you for advice.

Are you using Teensy based board?

To my knowledge this chip does not need to use program button.
You only need to press program button when using the loader. If you are uploading via Arduino there is no need to do so. Under Windows you probably need USB Serial driver installed as well since this chip/board might be in USB HID mode.

Yes, I use the advice.

I tried uploading firmware without a boot connector but it is not possible. In the arduine they throw an error.

It´s best if you can upload a picture or two of your board and the error.

Have you tried to compile the firmware in Arduino IDE then use loader to upload?

(This is more risky)I would recommend you try to burn the default bootloader using Arduino IDE then try upload again in IDE without pressing program button.

On this photos is board without boot connector and no reseting board. In PC i see PORT COM3…
Imgur
Imgur

Next i plug boot connector and press reset button. I see in PC AT90USB128 DFU…
Imgur
Imgur
In arduino…
Imgur

Imgur

I connecting my board without boot connector and without reset.
I see in the port: COM3

But i click on verify, arduino show me warning…