Hi, I just got a CTC 2nd generation (I think - black paint over wood body). I put a 3D file in the G format on an SD and put it in the 3D printer and it will not read it. Does any one know how to get a 3D file put on a card that this 3D printer can read please? I will deeply appreciate your advice please and thank you

I had the same issue. Solved it but using makerbot platform to create the 3g file. If you look at the file extension on the demo files you will see they match the makerbot file type.

1 Like

Makerbot printers and clones such as the ctc printer don’t read G-Code files, you will have to covert it using gpx converter or you can slice the model in replicator G or the makerbot software and export the file as an X3G file which is what makerbots read

1 Like

And, if you have the proper extension and file type, I have noticed the CTC’s are picky about the file name. They don’t like Spaces, special characters or lengthy file names. Keep it down to the 7.3 file name.

How are you finding your ctc printer so far anyway?

As everyone has said, you need .x3g files no straight gcode.

Thank you very much for this suggestion, I am going to try this!

Honestly, mixed emotions. The instructions are in Chinese, but I was able to read alternative sources and the pdf text enough to

print an impressive first print from the SD card provided with the printer. It looks awesome the firs print in orange PLA. It is the bust of a woman. However, after marveling at it for weeks I got bored and wanted a new challenge. This is where my problems kinda began. I downloaded and STL file and put in on the card and got into the world of trying to covert stl files to something this printer will recognize. It gives me this weird message so I thought maybe it was the mac I use and decided to try a microsoft platform. I formatted the SD card but the CTC printer requires FAT16 and my formatting options did not have that but did have FAT32 and a few others. I loaded up the card and got the same error message. Now I do not know whether or not it is the formatting in a non FAT16 format of the actual SD card that is the problem, or the aforementioned problem of converting the G file into a xG thingy (sorry guys I am a film maker and this stuff is like totally new to me I am trying to make a birthday present for my beloved sister so I am kinda clueless). In fact, I am scratching my head wondering and saying hmm because I did use the maker bot to convert the stl file into a G 'something and I could have sworn that G ‘something’ was the xG3 file or whatever…Im gonna be so embarrassed when i open that replicator program back up and see an option for the right file format smh lol…sorry guys…learning/growing pains

I’m sure you’ll get the hang of it soon, there is a button on replicator G which allows you to export straight to an SD card. However I haven’t really used replicator G as just kept crashing on me so I moved over to the makerbot software which Is a lot more stable. Once you a get to grips with the machine you should try updating the firmware to sailfish 7 if you haven’t already, it is better than the standard firmware that comes on the printer.

Honestly, I appreciate this post very much as I now realize (after reading it) that this may just be another reason it is not reading the card. I am going to remember what the error message is in case anyone has seen this error message before. Thank you!!

Happy to help:) if you have any other issues just post them on here

Thank you. I just tried to export the still file from the makerbot program. I did not see the option to export as a xg3 file for print on a CDC printer however, the only file extension option is makerbot when I try to export from the file menu. The “Export Print File” tab option on the far right gives me the option to export as a makerbot file as well. Do you know of any free, open source software that converts stl files to xg3 files anyone please? Sorry for all the questions guys.

Unfortunately there isn’t any software except replicator G and the makerbot software that exports .stl files as X3G however you can use a slicer such as slic3r and then the run the output file through a .GCODE converter such as GPX however it is much easier to use the makerbot software or replicator G

What firmware do you have on the printer, you may need a different file type depending on the firmware. I use xg3 in makerbot. I had a similar issue when I got my printer, I managed to just google.

Firmware version 1.0

is there something I can do to make the SC card read with this particular firmware?

The firmware version shows when I turn on the printer.

It beeps a noise and then displays the following on the screen:

The Creator

Firmware version 1.0