I’ve been printing with this machine for about a year or so now and I’ve really enjoyed it, but I’ve felt that the quality and complexity of my prints has been held back by the older slicers that came on the SD card.

A while back I tried using Cura as a slicer but ran into issues and resigned myself to my fate of using the most up to date version of MakerBot desktop.

Recently after more research I think I have most of the problems worked out using a newer version of Cura (3.2.1). However, I’m running into one final issue that I can’t seem to get passed; my printer will heat all elements to the specified temperature, but when the print begins, the temperature is set to 0 and everything starts cooling off.

Does anyone have a profile or group of settings that get’s this slicer and printer working in tandem? I’ve seen a lot of examples of the start and end g-code that worked for people, but they haven’t seemed to workout for me.

Start g-code:

M73 P0 ; Enable build progress

G28 X0 ; home X axis

G28 Y0 ; home Y axis

G162 X Y F3000 ; Home XY maximum

G161 Z F1200 ; Home Z minimum

G92 Z-5 ; Set Z to -5

G1 Z0 ; Move Z to 0

G161 Z F100 ; Home Z slowly

M132 X Y Z A B ; Recall home offsets

M135 T0 ; Load right extruder offsets

G1 X-110 Y-70 Z30 F9000 ; Move to wait position off table

G130 X20 Y20 Z20 A20 B20 ; Lower stepper Vrefs while heating

M126 S[fan_speed_pwm] ; Set fan speed

M140 S[bed0_temperature] T0 ; Heat buildplate

M134 T0 ; Stabilize bed temperature

M104 S[extruder0_temperature] T0 ; Heat right extruder

M104 S[extruder1_temperature] T1 ; Heat left extruder

M133 T0 ; Stabilize right extruder temperature

M133 T1 ; Stabilize left extruder temperature

G130 X127 Y127 Z40 A127 B127 ; Default stepper Vrefs

G92 A0 B0 ; Zero extruders

G1 X100 Y-75 F9000 ; Move to front right corner of bed

G1 Z0.3 F6000 ; Move down to purge

G1 X-90 Y-75 E24 F2000 ; Extrude a line of filament across the front edge of the bed

G1 X-100 Y-75 F180 ; Wait for ooze

G1 X-110 Y-75 F5000 ; Fast wipe

G1 Z0.5 F100 ; Lift

M73 P1 ; @body (notify GPX body has started)

End g-code:

M73 P100 ; end build progress

G28 X0 ; home X axis

G28 Y0 ; home Y axis

M84 ; disable motors

M107 ; turn off fan

G1 Z150 F1000 ; send Z axis to bottom of machine

M140 S0 T0 ; cool down HBP

M104 S0 T0 ; cool down right extruder

M104 S0 T1 ; cool down left extruder

M127 ; stop blower fan

G162 X Y F3000 ; home XY maximum

M18 ; disable stepper

M72 P1 ;

I have the Exact same problem. Were you able to fix it?

You could try the QIDI version of Cura. Send them an email to get a link to download.

Also, for the Tech-1 Flashprint will work since the machine is essentially the same as a Creator Pro 2016 style.

The most popular choice is Simplify3D but it will cost you.

Thank you. I’ll try flashprint but the engineer in me wants to figure it out… lol
I used the start code from flashforge in cura and it kinda works but gets stuck in the middle of the bed just before starting the print…

Problem is that all start scripts are not the same so parts of the one from Flashprint may not be recognized by Cura.
For instance, Cura may tell it how to heat and wait in one way while Flashprint uses slightly different code to do the same thing.