I’m a high school teacher starting a job on a campus that has a Mojo 3D printer. This printer has worked in the past, but the school recently upgraded a lot of hardware and software. For the life of me, I cannot get the printer driver installed. During the installation, I get a message that says the printer cannot be found and one following it saying Load Firmware Result: 4 or 8 depending on the computer I’m trying to install on.

I’ve tried with a Windows 8.1 machine with USB 3 ports and a Windows 7 machine with USB 2 ports. I’m doing everything the installer is telling me to do, but the software can’t see the printer.

Any ideas?

Edit: I was able to get in touch with Stratasys support and was asked to use the previous version of the Printer Software, which was 3.0. The installation did not work on my 8.1 machine, but it did go through on my Windows 7 machine. The printer needed a firmware update and I’m going to play around some more with the 8.1 computer now that it’s updated, but that’s for another day. The printer is currently printing and that makes me happy.

1 Like

Do you know what version of the software you have? The older versions of the software only ever successfully ran on Windows XP for me.

In our experience, you will have to let all usb ports always active, same for the disk, so you won’t get problems during printing. About recognition from windows we only could make the mojo recognizable in W7 Ultimate 64bit. Never changed that since then. I would try in a W10 computer instead of 8 that has too many probs

Hi Kevin,

Would you please share the name and location of your school by emailing applications.corporate@stratasys.com?

In my opinion this forum is about users and sharing experiences and helping each other, regardeless we all know that contacting stratasys, for example in this case, can give a more direct solution (with other “price” also!)



1 Like

I have the newest, 3.1.

I was on the phone with a tech a couple days ago and he wanted me to make sure I had the newest version, but then I got a response to my original email inquiry to stratasys and he wants me to try the 3.0 version.

I don’t have time to give it a shot today, but I’ll see if I’ll get time tomorrow to try again.

e: I’ll also try another USB cable. both laptops were detecting the printer, though.

Hi Kevin,

My name is Eddy and I’m from Stratasys Technical support. I came across your post here and am here to help. One of the best ways we can resolve your issues is through direct contact. Shoot me an email at FDM.support.us@stratasys.com so we can get that Mojo back up and running for you in no time. Just put ATTN Eddy in the subject line and have your printer serial number in the email body.

I see on your profile you are linked to Amsterdam? Is that Netherlands or one of the many US cities with the same name?


I finally got a chance to email you at the support email you gave me. the TLDR is, I was given the older 3.0 software to try. It didn’t work in Windows 8, but it did in Windows 7.