I have the PowerSpec Duplicator i3Plus (without auto level) Recently I purchased a Leveling Sensor (BTouch) and upgraded my firmware on both the mainboard (ADVi3pp-BLTouch-Mainboard Verr 4.0.0-alpha.3.hex) Melzi board w ATMega 2560 processor) through Cura and the LCD firmware flashed with ADVi3pp-Ver 4.0.0-alpha.3.-img. on a newly formated 8mg Sdcard. Now Cura is no longer communicating via the USB stating “Not connected” even thought when I plug the USB into my laptop I get the usual windows USB tone and the LCD has all the functions but most do nothing when selected or if they do react the response is “…In Progress” but does nothing. I then have to restart the system. When my laptop was communicating with the printer I tried to send a print from Cura and it said “Printing” but didnt. I tried the preheater which shows the temp I selected of 185 but nothing happens. I have to very honest Aurduino makes my head spin and it makes me feel like I have the IQ of a rock. This firmware required me to use it and Im 98.5% sure I forgot something or did something wrong! I dont know how to write code, frankly Im not even sure how to access the area where i need to adjust things other than the options in Cura. I really could use some direction(s) from someone who is patient enough to walk me through my infancy and get me printing again. I am seriously contemplating throwing it out and getting a new one because I cant seem to locate the original files the system came with on the SD card not anywhere and Wanhao literature isn’t very helpful.

I had a terrible time flashing my hardware for the first time. I tried doing it from my laptop as well. Over and over I failed. Then, I went and bought an Arduino UNO and compiled the Marlin Firmware on there. Fired up my printer and it worked right away. I’m a noob just like you lol. It all seemed so daunting at the time. Here I am, 3 months later, giving advice… who would believe it?