WANHAO Duplicator i3 Plus. Fresh out of the box. X endstop not working



It just keeps going, even if I press the button manually.

I think I’ll have to open it up and check if any cables are loose from shipping. As anyone here already one of these? It looks like a ridiculously tedious task, so many screws …


Ok, I have had this happen.

1. Check that you have removed all the packing tape securing the cables and bed.

2. Check that you have plugged the end-stops all in.

3. Ensure the bed is actually clicking the end-stop and not being blocked by a cable or or something else

4. Check the alignment of your end-stop by physically moving the bed to the end-stop and listening for the click it makes when coming into contact with it.

5. If all that does not work, you may have a lose cable in the control box, but this is unlikely as the cables are all glued in place on the MB.

Hope that helps!



If it fresh out of the box, I’d be sending it back and asking for a replacement rather than messing myself.


I would concur with the last comment except that replacements usually take 2 or three months.


i think maybe if your looking for 100% efficassy from a hobbiest machine or are not prepared to “fiddle” with the machine you better pack it back up and send it back on a return, instead may i offer most humbly the suggestion that you pay 5,000 to a local 3d printer supplier and get them to install and run the first print. but then when something goes wrong, and it will, youll have to pay to get them out again. your choice? get youe hands dirty and learn like we all have had to, is my advice and remember the old buddist rule. The fum is in the journey not the arrival. :slight_smile: StevetheBuddistXXX


Have you tried the other end stops to see if they’ve just been switched over by mistake?


I had a similar problem with my wanhao i3,

The heater to the nozzle and bed were interchanged, so I had to correct it

  1. You will need to open up the box and check if the wiring is ok and has been plugged in properly.

  2. The end stop wire might also be cut somewhere in the middle so you may have to check if that fine.

  3. After checking both the issues if it is still not working i would suggest buying a new limit switch as it does not cost much !!

Hope this helps !


i agree


I managed to plug my switch connector in at 90 degrees to how it should be - once my local guru saw the problem he called me an idiot and plugged it in properly. It should be easy enough to test if the wiring is connected by using a small piece of wire to short the terminals in place of the switch