Wanhao i3 Mini: Firmware

wanhao

#7

I have since emailed Mikey at Wanhao. He kindly sent me a HEX version of the V1.3(B) firmware, which will load though Cura >Machine>Install Custom Firmware. The only problem is: my Board appears to have an older version of EEPROM, so the printer, which was working apart from a temperature readout offset of +43 degrees, is now not working at all. I have no recovery from this unless Mikey sends me a compatible (older?) HEX file.

I too am thinking about swapping out for a RAMPS 1.4 + LCD Display, which is considerably cheaper than a replacement Wanhao board. I would prefer not to do this, as the space requirements are much greater, and will undoubtedly require some sort of external casework.

I hope to obtain all the required settings for Ramps 1.4 Marlin Configuration.h, in the i3mini.rar Configuration.h file

Cura option to ‘Install Default Firmware’ is greyed out, which is a shame, as this would be the best option. I was disappointed not to find this on the supplied SD card.


#8

Mikey kindly sent 3 versions of the HEX file, and i3mini-wanhao-v1.3.hex installed correctly, and solved the issue.

i3mini-wanhao-130X160X130.hex Also worked, with increased travel, a different display, and other Advanced menu changes.


#9

is there any chance you can share that 130x160x130 file somewhere on google or so ?


#10

Hi,

I would be happy to do so, but don’t know how to ‘share’ the file through the forum.

If you need the file, soon, perhaps you could contact Mikey at wanhao , his email address is on their website.


#11

thank you for your reply.

maybe through google drive or similar ?

I recompiled the firmware that was published but can not get past 130X 155Y 110 Z
just want to check if the enhanced bed firmware you have would work at all


#12

Hi,

You’re welcome. Google drive is beyond me, I have no access, no real experience, or knowledge on how to share files.

The Hex file, installed through Cura , works perfectly. Best contact Wanhao direct


#13

You are both lucky if you are getting more than 150mm. Mine I get X115, Y135, Z100. Travel is limited physically, I will need a mod to make it any bigger.

Suspected the file supplied by Mikey is an older revision of the firmware 1.1.4 and for sure not the same settings as the OEM. Getting a hold of Power Spec is harder than reaching Wanhao.


#14

Hi,

I only got this printer a week ago, and have yet to confirm actual travel, but HEX file works. This is the file name
i3mini-wanhao-130X160X130.hex

Cannot comment on firmware version, but Standard firmware file name supplied by Mikey, at the same time, is i3mini-wanhao-v1.3.hex

With regard to contacting Wanhao: I have found them to be really good, with quick response times, and good answers. Just have to allow for time difference.


#15

as can be see way back at the start, 1.3 is the ONLY thing that Wanhao has offered, amd have seen all flavors of it but not installed as I suspect they are older versions of Marlin.

Mine is 1.1.4 as from Powerspec. Though it clearly states this one is a Wanhao i3 Mini. (details in OP).
I would like to update to 1.1.8, but lack the specific configuration.h data, and a few other tweaks for the Mini. If I can round this up, I will make it available so that every one has the ability to generate updates for their machine as needed.

Manualy sending code M501, then M503, should result in a fairly solid regurgitation of just about everything the PCB is able to tell you.


#16

Sample provided for putput. Do not try to use codes that are listed as output less you are ready for bad thinsg to happen or know how to use all of these codes. Please only use M501 and M503 to grab a data dump. M303, Numbers generated if your firmware supports the function, are to added to the Configuration file. Do not use if you are not looking to re-calibrate your heater data.

M501
FIRMWARE_NAME:Marlin 1.1.4 (Github)
SOURCE_CODE_URL: https://github.com/MarlinFirmware/Marlin
PROTOCOL_VERSION:1.0
MACHINE_TYPE:3D Printer
EXTRUDER_COUNT:1
UUID:xxx
Cap:EEPROM:1
Cap:AUTOREPORT_TEMP:1
Cap:PROGRESS:0
Cap:PRINT_JOB:1
Cap:AUTOLEVEL:0
Cap:Z_PROBE:1
Cap:LEVELING_DATA:1
Cap:SOFTWARE_POWER:0
Cap:TOGGLE_LIGHTS:0
Cap:CASE_LIGHT_BRIGHTNESS:0
Cap:EMERGENCY_PARSER:0

M503
Marlin 1.1.4
Last Updated: 2017-07-04 12:00 | Author: (none, default config)
Compiled: Nov 2 2017
Free Memory: 3261 PlannerBufferBytes: 1232
V12 stored settings retrieved (445 bytes; crc 10054)
G21 ; Units in mm
M149 C ; Units in Celsius
Filament settings: Disabled
M200 D1.75
M200 D0
Steps per unit:
M92 X80.00 Y80.00 Z400.00 E94.00
Maximum feedrates (units/s):
M203 X300.00 Y300.00 Z5.00 E25.00
Maximum Acceleration (units/s2):
M201 X3000 Y3000 Z100 E3000
Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
M204 P800.00 R800.00 T1000.00
Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
M205 S0.00 T0.00 B20000 X10.00 Y10.00 Z0.40 E1.00
Home offset:
M206 X0.00 Y0.00 Z0.00
Mesh Bed Leveling:
M420 S0 Z0.00
G29 S3 X1 Y1 Z0.00000
G29 S3 X2 Y1 Z0.00000
G29 S3 X1 Y2 Z0.00000
G29 S3 X2 Y2 Z0.00000
Material heatup parameters:
M145 S0 H244 B70 F0
M145 S1 H240 B110 F0
PID settings:
M301 P32.50 I2.86 D92.52
LCD Contrast:
M250 C200
Z-Probe Offset (mm):
M851 Z0.00
Active Extruder: 0
echo:SD card ok

M303 (AUTO TUNE)
Kp 32.50
Ki 2.85
Kd 92.52


#17

I have flashed hex that was provided from Mikey, and all is good BUT im missing option to level bed, andyone know solution? or how to accesses it? since on my printer now its MIA


#18

I remember there being a flag in the files to turn that option on and off but i do not recall where. For the time being, if you run Simplify 3D they have a function built in that does much the same thing as it just moves the head to each corner and Z=0. You still have to turn the screw until it is set right. You should also be able to use a control panel to either send hand written code to tell the head where to go.


#19

i just got .hex file from wanhao Mikey, as i know its complied and i cant change anything in it?, i wrote to him about this and he sent me original hex, but i want bigger print are those 20mm from Z means alot to me, guess ill have to use simplify 3d for leveling for now :frowning:


#20

I can put the hex on a google drive somewhere , or you can use the TH3 Unified firmware and compiel yourself and uplaod that one, that way you have 1.1.18 Marlin as well with all that comes with it.


#21

Care to explain, whats config of your hex and its for i3 mini right?


#22

I just downloaded the TH3 unfified firmware , compiled and uploaded, works perfect.
no settings needed as supported natively by this frmware.


#23

That’s custom firmware. Looking to enable all of us to compile as needed. Not pay some one else to do it. However, thanks for the note. I have looked at THD.


#24

I sincerely hope that you got a solution to your 3d Printer’s trouble as the solution to this is something really hard to manage. I actually needed to call an expert to resolve the z-axis troubles with my Wanhao 3D printer.


#25

Steve, if you look in the notes left on github. Mikey says something about having added code to deal with a z-axis issue.

It is off topic, but what issue are you having?


#26

In what version he has fixed z? 1.3 or 130x160x130 hex?