Hello everybody,

yesterday I have updated the Z-suite and the firmware (1.02) on my Zortrax M200 printer. Than I printed a pretty simple part with support. After the print finished, I tried to remove the support from the part, but unfortunately that was impossible. The part and the support stuck “perfect” together, and there was no way to separate them. What I find very interesting, because I printed the same part about 3 day before the update, and I could remove the support very easy (as I’m used to this). Therefore I think, that either the software update or the the firmware update may cause the issue. Has someone else noticed this?

i can confirm same over here, did the testprint of marvin cant remove the support on eyes had to cut it with a knife looks terrible, shame on zortrax !

Yes - I have noticed the same thing. Since the update the raft is hard to pull away from the model. Zortrax - hope your listening!!

Depends on material printed and the time between the end of the print and the removal. I left the printer in sleep mode for hours and then when i tried to remove the suppor was hard so I heated the base, await few minutes and then remove the remaining part

I guess its two years since you submit this post and supports still suck, its absolutely nightmare. Im stun because it seems like Zortrax really follow all request from users but this one its just a joke. You can check their site, this is no.1 request but with new update z-suit 2 its even worst. I don`t know how this is even possible. I hope they will fix this till my printer will die.