ANet A8 Tries to print in midair

I am BRAND spanking new to 3d printing.  This is my first printer.  I use a Macbook Pro, so I am using Cura to open .STL files, convert them to gcode, save to an 8GB Micro SD card that I then put in the printer and print from file.  Took me an entire day to assemble it, but finally got it all together, but I have a few issues I need to try to get solved and NO idea how to solve them:

 

First, when I Home All from the printer control menu on the printer, the print head goes full forward left and then the Left/Right stepper motor grinds for about 5 seconds.  It's hitting the limit switch, but it doesn't seem to make any difference.  ???

 

Second, I have a self leveler on order (not idea how that works or where it goes yet - hoping for good instructions).  I would IMAGINE that you would have to teach the printer where it's printer bed starts and ends in X and Y axis, but have NO idea how to do that - EVEN if it is required.  Instructions are pretty rudimentary and mot much help.  It seems to leave the extruder at the distance above the print bed that I set manually, but as soon as I go to print a file, it goes to the middle of the print bed, where I would think it should, then raises the extruder until it's about 15-35 mm off the surface of the bed and then starts printing (well, making copious amounts of thin plastic string).  I CAN NOT seem to get it to put it where it belongs, at least on teh Z axis anyway.

 

Can someone give me some suggestions to fix these so I can stop pulling my hair out and start using it please?

 

Thanks in advance for your time!

+1
0
-1

Hi!

I would also assume that there is something wrong with your Endstops (not or wrong connected, broken switches...).

First of all: welcome to the wonderland 3D Printing :D

 

I would strongly recommend to download the programm "Pronterface" (https://github.com/kliment/Printrun). This is a tiny little helper which should be in every 3D printing toolbox.

With this programm you can connect to your printer using the USB connection and directly command it. This brings me to the next step: G-Codes. Get familiar with them! (http://marlinfw.org/meta/gcode/)

If everything is well configured you will rarely need them, but with the Anet A8 I would strongly recommend to bookmark the link to the overview ;).

 

Because you can now do this to check if the endstops are working:

1. Connect to your printer using Pronterface

2. Send the command to get the status of your endstops using the console in Pronterface (GCode M119)

3. Now press one endstop after another and check if the CORRECT status is changing to "triggered". If not there is something wrong with the endstop

 

Now, let's shortly talk about autobed leveling. It is true that there is not "the one" instruction to let your printer do autobed leveling. This one was very helpful for me (http://www.instructables.com/id/Anet-A8-Prusa-I3-Auto-Leveling-Using-NPN...), but also I needed a lot of self-investigation.

I would recommend you to also get familiar with flashing and configuring the Marlin firmware. For this download the latest Skynet3D release (Skynet3D is a preconfigured Marlin for the Anet A8), compile it and flash it onto your Anet.

If this is working, have a look at the Configuration.h. In this file you will find a lot of settings which will all answer your questions. For example you can set the distance from the home position to the beginning of the bed, this way the printer "knows" where the bed starts and ends. Or the "safe-home" setting which you will need if you are using a sensor for the Z-axis. Otherwise the print head will try to home at the current position and will potentially crash into your printbed.

 

I hope this answer directed you a little bit in the correct direction.

+1
0
-1

It does not look like you have installed the z-stop and x-stop sensors correctly. Maybe you have them swapped. If you download arduino program, you can connect it to the board via serial monitor(115200 baud). Once you connect to it, you can troubleshoot the problem but issuing M119 command to see the sensors work.

+1
0
-1

wish there was someone local to Denver Colorado that I could ask for help.  Just not getting this.....

+1
0
-1

OK - I swapped the sensors, and no more grinding, now the extruder homes at the right height, very front of the platform, in the middle, but a new problem.  Now the right side Z motor does not stop trying to go down, it just keeps going and doesn't stop.  Have not tried another print yet, but imagine it's still going to try to print it in mid-air.  I read somewhere in another forum this can be related to teh SD card I am using?  I am using hte 8 GB card that came with it, but others said they solved such problems by downgrading to a 2 GB card?

+1
0
-1

Both Z-motors are connected to the same stepper motor driver on the board even they are two sockets, so there is no reason one motor won't stop if the other one stops unless it is connected to a wrong socket.

+1
0
-1

I think I've figured out why one appears to stop and the other doesn't (Z motors):  The one is being physically restrained from going any further by the micro switch and mount, the other isne't.  HOWEVER - that means they are not seeing the limit switch, which I'm pretty sure is plugged into the right socket.....

+1
0
-1

Have you figured it out? I saw some people have similar problems with different stop sensors in other forum. Someone fixed the problem by re-soldering R37, R38 and R39 on the board.

+1
0
-1

I have not, though that is interesting.  I never thought to check the quality of the solder connections on the board.  I did finally give up and take it to a 3d printer repair shop to see if they could figure it out.

+1
0
-1

Try to test the switch using Pronterface. The Z-Endstop must change to "TRIGGERED" if you press it down manually.

Or move the Z axis up, do an "Auto Home" and press the trigger while the axis is moving down. The movement should stop immediately.

+1
0
-1

Follow my instructions from my answer above and download Pronterface and connect to your printer. Now you can manually try to rise and lower the Z axis a little bit for testing. Also try all other axis. And try all the sensors. I assume the Z motor is also connected wrong but with Pronterface you can check everything step after step.

+1
0
-1

I don't have an Ardunio board to connect to it.  What program would I be looking for?

Not the answer you’re looking for? Ask a new question to 486 ANET 3D experts active on Talk.

The 3D Printing Handbook is available now

If you’re a professional looking to master the key aspects of 3D printing, this book is for you.

The 3D printing handbook