I have a CTC Bizer (Clone of Replicator 1 Dual Extruder), everything works fine, the printer works, the issue is with the slicer.

The given SD had ReplicatorG and MakerWare. MakerWare doesn’t work, it says that the background service is not running, if I try to restart it, it simply won’t start, so no slicing at all. I also downloaded MakerBot Desktop, which seems to be the latest version of MakerWare, it simply doesn’t slice files over a certain size. I tried to print the 10MB 3DBenchy.stl from http://www.thingiverse.com/thing:763622/#files - it simply won’t slice it. I have another 16MB part and it won’t slice that too. MakerBot Desktop simply shows an empty view in the “Preview” screen, stating there are 0 layers and exports a 0B (empty) x3g file. Smaller files get sliced without issues, but top and bottom layer are underextruded, so it leaves giant holes in the prints. Also, MakerBot Desktop leaves gaps between the filling and the shell.

I also tried Cura and Slic3r post-processing gcode files with ReplicatorG or GPX in order to make x3g files out of them (as that printer doesn’t read plain gcode files), I can’t get it to work, if I print something, the build plate goes down and down, then it starts vibrating as soon as it reachs the printer ground (like if it’s trying to go even further down).

I’m attaching some pictures of the Makerbot Desktop with the 3DBenchy and empty preview, and also two photos of the CTC Bizer spool holder I tried to print (which show underextrusion - so gaps of course - and gaps between shell and infill).

Is there anyone who can help?

Thank you

1 Like

Spend the money on simplify 3d. It’s the best thing you’re going to do. Also, update to sailfish before you burn out your board. After that look online for mod for ctc and do the main ones to get much nicer prints.

I am using S3d also and even though it is for pay it was worth it to me. I can’t really comment of the other slicers since I have not used them really. RepG a bit and it was ok for what it is.

Does Simplify3D save to x3g? I already have Sailfish 7.7, and I was also wondering: is there any firmware capable of reading the standard gcode?

I hear lots of people telling to buy S3D but I use it for hobby, so spending $150 for a professional program is something I’d like to avoid, if not really necessary. Also, S3D doesn’t have a trial version, which would be really useful to test its potential before deciding to pay that amount.

I use Matter Slice (Matter Control) as my slicer. However, I agree with the other posts, if you can spend the money for simplify3d then do it. With Matter Slice you can actually connect to your printer via USB if you want or export to SD card. It allows you to export straight to x3g. When I get home later tonight, I can upload my configuration file for my printer. However, for now they have a profile for the flashforge creator pro that works just fine. My profile just has a few tweaks to work better with my printer.

To get the slicer, go to mattercontrol.com.

I had the same problem that you are having right now with my prints. Again, when I get home, I will see what I can do to help you out.

Yes it does. I also 3d print as a hobby aND I used makerware at first with proftweak. I learned alot then after 3 month I got s3d and it’s worth the cost even for a hobbyst. I know there is no trial, but look at YouTube videos, get familiar with it from videos and make a decision.

Thanks, I’ll wait! Do you have the same printer?

I have the same printer. However, I think I have a different version because mine is just unpainted laser cut wood and everyone else has one that is metal or painted wood. These are the settings I am using to control my printer. With this slicing software, you can use Cura, Slic3r, or Matter Slice. I use Matter Slice. I would play around the settings that I have attached. You are going to want to tune this to fit your printer better.

I have been getting some pretty good prints with these settings. You may want to change around layer height to fit what you need though. If you are trying to go for something that needs a lot of detail, try lowing the speeds of the print and increasing layer height. As for layer height. The lowest I have gone so far is 50 Microns. I have printed several prints at that quality and it is difficult to see the lines in the print.

The problem you are having is that the top faces are not closing. I have this set to 8 layers on the top and bottom and that has been working. You may be able to cut down on layers if you have a cooling fan that you can blow directly on the print. You may also want to try increasing infill to support the top layer.

With the configuration file, I need to let you know a few things. Under the Printer tab, and under Features. You can turn parts of the printer on and off. My heated build plate is currently not working so I have it turned off. If you have a heated build plate turn it on here. Also, please be careful on this screen. You may be able to do some damage to the printer on this screen.

Also, with the dual extrudes I am having some difficulty with them lining up. I think I have the offset set properly but I am not sure. The left extruder on my printer is jammed so I can’t really test it. However, I think I have the offset set properly. To change this got to the Printer tab, then to Extruder. Also, if you want to do an extended build plate with your printer, you can change that under the print area options.

If you have any problems with this file please let me know and I will help you out. To load this file you first need to add the FlashForge Creator Pro Dual printer using the add printer menu. Then click Settings & Controls, then click Options then import. This should change all your settings to match the file. Also, you will want to change your settings from Basic to Advanced to change some of the things I talked about previously.

For connecting to the printer, I can’t really help to much. I export my files to SD card and print directly from the printer. I do this because the USB connection on my printer does not work at all. So no Sailfish upgrade :(. Anyways, I have connected over USB with my M3D Micro and it works fairly well. You can set prints to email, and text you when they finish and you can monitor them online.

However, I would use this software to get you by. When you get a chance I recommend that you pickup Simplify3D. They do have a 30 day money back guarantee if you do not like the software. I agree though, I trial would give me a lot more trust in their software.

Also, here is the link to the config file. I had to put it in a zip because everywhere I uploaded it, it wanted to display as text instead of a file. Anyways, here is the link: https://dl.dropboxusercontent.com/u/229079674/CTC%20Bizer%20Config.zip

You say I can use Cura too… How? As far as I know Cura is not capable of exporting x3g files… I have tried Matter Slice too, imported the model, clicked on “generate” button and a window saying “NullReferenceException” popped up…

Sorry for the delay.

I am not 100% sure but I think MatterControl uses Java. Try updating your Java and see if that works. Also, the MatterControl community is very helpful. They can help you get it running if you keep having problems.

Also, for Cura you can generate the files in GCode then use ReplicatorG to convert it to x3g. However, I have never got this to work. Maybe you will have better luck.

When I mentioned Cura and Slic3r. I meant that MatterControl comes packaged with three slicing engines. Cura, Slic3r, and MatterSlice. Got into the settings of your printer, then click options, then you can change the slice engine there. Then your options will change to suite the engine.

Also, you can export x3g from Cura with a plugin but I can not find the plugin. I have found something that works along side Cura to convert Gcode to x3g but I have never got any of that to work.

No, a NullReferenceException comes from a .NET application, Java has a similar one but it’s called NullPointerException. I already have .NET up to date. I never got gcode to x3g conversion to work neither, as I stated in the post.

For the error: I checked the settings, fill density was set at 0.3%, I changed it to 15% and it sliced, I think this was the messy option. I also found the setting to use CuraEngine to slice, I’m trying it now :slight_smile: Thank you! Anyway, I think we have the same printer, I have the wood one too.

Weird thing. I tried to slice the same model with Cura and MatterControl using CuraEngine.

Cura settings:

50mm/s print speed

50mm/s infill speed

30mm/s outer wall speed

40mm/s inner wall speed

15mm/s bottom layer speed

20% infill

MatterControl settings:

130mm/s infill speed

130mm/s inside perimeters

120mm/s outside perimeters

150mm/s travel speed

15mm/s first layer speed

20% infill

Cura says it takes 1 hour for the model to print (with lower speeds than MatterControl)

MatterControl (with CuraEngine) says it takes 2:41 hours to print - with significantly higher speeds.

Something is going wrong here, is it ignoring my settings??

I am going to agree with the others here that simplify3d is the answer to all your ills. It is the best investment you can make in your printer.

That being said, it is so easy to put my hand in your pocket and tell you to spend the money. But sometimes folks are just not in a position to do so.

As such, I would recommend flashforges flashprint as an alternative. It will get you good prints, but not give you the control of s3d in getting to great prints.

It is free.

I can’t help with everything else, but are you using makerware on ubuntu 16.10 by any chance? I was getting the same background service issue and after emailing makerbot they said that they support 16.04 LTS but not 16.10. Not a great help, but I have the same issue. Been dual booting into windows just for it.

Sorry for not getting back to you sooner, been busy. Were you able to get x3g export working in MatterControl?

I use simplify 3d and i is a lot better than mb’s software

Could you be persuaded to reupload the settings above? (if you still have them)

I am having similar problems and can’t seem to figure out the correct settings for my printer (also a CTC Bizer Dual Extruder).