Hi everyone

I’m setting the Marlin firmware to flash it on a Megatronics v3 (my leapfrog board doesn’t works anymore.

I’d need to know some info to set it properly so I hope someone of you may help me.

Tepreature:

do you know the specs of thermistor and heater cartrige? Wich option should I set on Configuration.h?

same thing for the bed, for the Vref on A4988 drivers (the original board comes with DRV8825), step/mm for all the axis and extruder.

I’ll probably will ask for some more info but for now that’s all.

Thank you.

1 Like

Hi,

I’ve done exactly the same thing. I can send you a customized Marlin Firmware for Megatronics v3, but I urge you to download the correct firmware version for your printer’s original board and copy and paste those values.

The stepper driver’s should all be set for 1/16th step for all the NEMA 17 steppers and 1/32th for the NEMA 21. The z-axis magnetic end-stop should connect the the Z- (-) plug. As long as the firmware is configured correctly it should all work as before.

PM me if you need any more help.

hello,

I had the same issue, i replaced that board 3 times, than finaly i switched to ramps1.4. The temp sensor settings is as follows for the leapfrog Creatr:

#define TEMP_SENSOR_0 1
#define TEMP_SENSOR_1 1
#define TEMP_SENSOR_2 0
#define TEMP_SENSOR_BED 1

as far as the motor drivers i had trouble with the A4988 drivers not capable to delever enough current to the Z and was getting too hot on the Y axis since it was powering 2 motors. so i ended up buying the DRV8825 modules which are pin compatible to the A4988 module but can deliver more current.

than it worked like a charm.

hope this is helpfull.

Rafic Bsat.

Thank you Antonio and Rafic, I’ll follow your suggestions.

I’ve found the firmware of reference for my printer here

http://support.lpfrg.com/support/solutions/articles/1000084056-which-firmware-version-do-i-need-for-my-creatr-printer-

I’ve downloaded it and I’ve copied the parameters on the last version of Marlin, downloaded form github

Because I’m going to use some e3D v6 full metal extruder I’ve put a quite high max temp for the extruders (310°C) to print technical materials, I hope the thermistor will handle the temp (otherwise I’ll find a different solution). I’ve red somewhere that the e3D thermistor doesn’t handle temps above 295°C: any suggestion to swap it?

Another thing I’ve to verify is the step per unit; I’ve put the same value of the Creatr original fw but using A4988 so what I expect is that moves will be doubled. One more time is something to verify. (at the end I’ll use DRV8825 as soon as I recieve them).

I hope this topic may grow to be helpful for more people; unfortunatelly the system doesn’t allows to upload zip folders; if it has not been done so long I’ll fork Marlin for Megatronics v3/Creatr on github asap so anyone can find and contribute there :wink:

Hi Antonio, thanks for your help.

On the original leapfrog board there was 3 jumpers that set the DRV8825 at 1/32 step. With this configuration the step per mm on the fw were set as follows

#define DEFAULT_AXIS_STEPS_PER_UNIT { 33.33*4, 33.33*4, 9600/5, 55.465*4} // default steps per unit for creatr with spindles

Now I’m going to test A4988 (because I’ve just that drivers right now); I should halve those values to work properly, isn’t it?

From where comes from that 33.33? and what’s that 4?

Why the X/Y values are so different from the E value?

9600 means that the NEMA21 is a 300step per revolution right? it’s a deduction but there’s no trace of labels on motors.

Thank you for your support.

Sorry for only replying now.

I saw it on my smartphone and meant to get back to you later in the day when I got back home and just forgot.

This is how my tested setup works (again, 1/16 for the NEMA17s and 1/32 for NEMA 21):

#define DEFAULT_AXIS_STEPS_PER_UNIT {33.33*2, 33.33*2, 6400/5,55.465*2}

You can quickly see if you’re doing it right by making homing all axis and making it travel 100mm in each direction. If it doesn’t end up halfway along the Z and slightly less than half for X and Y just adjust the multiplier.

I tried the 1/32 step but it didn’t work all that well. Perhaps I had the stepper drivers improperly adjusted but I don’t think that was the case. If you find out it was please let me know.

If need be I can send you a small adapter a colleague helped me make to screw the Megatronics to the original board’s screw holes. It’s not fancy (actually its misaligned in one of the screw holes) but it works.

Best regards,

I’m not sure if it will handle prolonged use but it did hold out for a short burst.

I know because the way I shorted one of the first boards was because the machine isn’t properly grounded and while using it at a machine lab at my Uni which has tree-phase plugs for heavy machinery connected to the same mains board as the regular mono-phase power sockets, some computers (particularly desktops and older notebooks) would have a weird effect on any connected board, particularly turning on one of the heater MOSFETs without any temp controller as soon as the USB was connected to the computer. If it was a desktop it seemed to be caused by having a monitor connected to it, and if it was an old CRT monitor it would send a very high voltage signal and actually fry the board (while still feeding the heater head MOSFET).

Anyway, when this happened with the Megatronics it was at first with the same old PC that fried the replacement Leapfrog board (first one was because of short due to sawed off heater cable short) and the second time with a very old Acer laptop which I did not expect to cause this. I think the temperature got up to about 340 °C (first time it happened probably got a lot hotter and I only noticed when I saw smoke coming out the top) but it didn’t blow the thermistor, but again, it was only for relatively short bursts of time, not continued use.

The Megatronics also has thermocouple inputs and those can sustain much higher temperatures, but the trade off is the lack of temp resolution:

«The main limitation with thermocouples is accuracy; system errors of less than one degree Celsius (°C) can be difficult to achieve.» - https://en.wikipedia.org/wiki/Thermocouple

Best regards,

Hello everybody :slight_smile:

Antonio, thanks for your support and nevermind for the delay :wink:

DISCLAIMER

Maybe I write a little bit too much, with too much details. Shouldn’t I go straight to the point?

Sure I can, but I prefer to write more to take trace of what I’ve done and to let other people to follow this path whatever works, so please forgive me if it looks a little bit long :slight_smile:

I’ve modified the firmware a little following original leapfrog firmware values and your suggestions. It compiles.

I’ve uploaded some days ago and everything was fine but I’ve not tested the board for movements or heating).

Today I’ve made some test using Repetier Host.

1. push X home - motor seems ti move but it actually doesn’t; maybe I’ve to fix the Vref on the drivers (remember that I’m using A4988, not DRV8825 ?);

2. push Y home - nothing, not even a noise; connection checked, it’s ok.

3. push Z+ and Z- and the motor moves as expected.

4. Turning on the heater n.1 it goes to the max temp on the screen but the extruder is actually cold (room temp of course). Thermistor reads a temp.

Because of those strange behaviours I’ve tried to upload the firmware for test I’ve found on the wikipage

When connected with repetier host it starts to beep (sounds like an alarm, some red leds blinks sequantially at the center of the board, one of them (LE0) is still, TX blik fast and DBG blik slow.

Motors X and Y vibrate a bit and if I try to push manually the Y carriage the sound become a bit softer.

What does it means? I’ve looked online for some documentation but I’ven’t found any.

Someone may help me with the firmware test?

Waaaait

I’ve just found this

So thank you mr outbound-pt from Lisbon :wink:

I’m going to try your firmware right now :))))

On the README.md we can read:

“This uploaded firmware is the first attempt at getting the board setup and is untested on the machine. It has been uploaded to the board and it generates the error message expected when it doesn’t detect any valid signal from the thermistors, forcing it to shut down.”

is this still true or it has been fixed? what should I expect?

p.s. thank you for the adapter for the Mv3 but I’ve just made mine with a cnc and a piece of metacrilate :wink:

p.p.s: Outbound you’r becoming my point of reference for this issue, now I’m following your topics on RR forum :slight_smile:

ok, I’ve just read this on endstop connections, this about compilation error on sensitive_pins and also this about the heater turning on because of a ground loop. Now we are brothers in arms :slight_smile:

What I’ve done has been just to connect the Z sole lead to the negative of Zmin on the board as suggested in the first link.

The Megatronic still buzs.

OK, so that was a very early version and I don’t think I ever uploaded a working version. I’ll try and upload a more recent working version to Github (I never got the hang of properly forking and submitting a push or whatever). The sensitive_pins were no longer an issue when I used an up to date version of Marlin. That first version was something that, for whatever reason, I downloaded from a Google search and it was outdated as pointed out by people on the forum. The latest ones I used were either the RC Bug fix or the supplied Marlin firmware for the Megatronics (you get this in user restricted page of reprapworld.com. I also had trouble finding it at first).

Also, the test firmware will get you no where in terms of controlling the machine. It’s only meant to test out all the MOSFETS, stepper drivers and buzzer so as to check whether everything is working or not. If it’s not you send it back within a month and they give you a replacement.

I’ll give you a heads up if I can upload a working version of the firmware to that Github page. If not I can just e-mail it to you.

Also, you have to look into your stepper driver settings and figure out the correct configuration. I had the same problem you speak of and I think that’s how I figured out that the stepper resolution was incorrectly setup.

So I was going nuts trying to update the repository so I hope you can just use this. Keep in mind I switched the Z-axis and Y-axis pins because I had earlier separated the parallel connection to the Y-axis steppers so I needed to use the dual outputs of the Z-axis. Just switch them back in the pins.h file if you want to keep the normal configuration.

Hopefully this link will work.

Best regards,

thank you :slight_smile: I’ve wrote a more detailed post in the RR forum, general section. I should paste it here too… see you \m/_

Hello.

Where are you from your modification?