[SOLVED] Anet A8 will not print on bed

anet-3d

#1

[SOLUTION]

First, my z axis end stop was too low, so I fixed it to be at the right height. I actually did that while installing Skynet by following this tutorial on the official GitHub.

https://github.com/thijsk/Skynet3d

I used Cura 15.04.6’s Pronterface UI window to adjust the extruder to exactly the right height down to the 0.1mm and then set the end stop.

Next, I installed Skynet for the printer and put the settings given in the GitHub into my printer. (Note: My printer does not have a leveling sensor so I did not touch the Start/End-GCode)

I then leveled the print bed using the paper method linked in a reply below.

After all that, I ran a test print of a small cube and it worked like a charm!

Thank you all for your help, I learned a lot through all this. :slight_smile:

_______________________________________________________________

[ORIGINAL PROBLEM]

I am extremely new to 3D printing so I’m not too familiar with how to set all these things up but I just got an Anet A8 printer for xmas and I put it together correctly but when I go to print things it moves the bed to the back end stop and moves the extruder to the left and bottom end stops. Then, without moving back to the center, the machine starts trying to print.

I am using Cura 3.1.0 as my slicer. I have attached pictures of my print settings and my machine settings. When I looked up posts where people had similar problems there was usually a reference to a setting called “Machine center at 0” in machine settings but it is no longer there.

I pretty much built the thing, plugged it in and started trying to print, so did I miss a step in calibrating it? If so, how do I do that? Should I be changing my Cura settings? Should I be using a different flavor of GCode?


#2

Click on settings printer manage printer

Then click on machine settings

make sure x and y are 220 and z is 240

make sure there is no check in origin at center and while you are there check material diameter. 1.75


#3

I already have all of those settings but it still prints off the bed


#4

I was having the same problem with the new cura and unchecking the “origin at center” helped me but it looks like you already tried that. make sure you’re updating you gcode and not using the same old one. I think the anet firmware is based off of marlin but im not too sure.


#5

What should I be updating it to?


#6

The printer should work just fine with the factory firmware but there is a custom firmware out there called skynet I don’t think it will fix your problem but if you want to give it a shot here is a youtube tutorial https://www.youtube.com/watch?v=Qu_gUKdDOR8 .

It sounds to me like you’ve unchecked the “machine center at zero” and just used an old gcode file. try deleting all your old gcode files to make sure you get a new one.

A video of the machine printing might help with a diagnosis


#7

I’ll try skynet. Here is a google drive link to a video of the print error. The website won’t allow me to post a video.

https://drive.google.com/file/d/1E8IDFLh2bfXqQ-I4nC36726oEzgIbLZM/view?usp=sharing


#8

it looks like the nozzle is below the bed. If that is the case then your z endstop is not set right


#9

how about a video of the z endstop when you tell it to home


#10

Hit me up on facebook and I will try to help you in real time. Stanley Oberheim


#11

I fixed that a few minutes ago and I’m also installing Skynet and setting up cura 15.04.6.


#12

yes - move your z stop switch up until your print head homes over the bed and make sure you level your bed. this is the toughest thing about 3d printing but when you master it, it will get easier and easier. https://www.youtube.com/watch?v=L6GJWHwrTmY

you can get an auto level for the a8 but it is not magic and manually leveling will almost always produce superior results.


#13

stop skynet is outdated. its an OLD version of marlin. and the newest cura are much better


#14

Three names come up. What’s your profile pic?


#15

charlie brown and snoopy


#16

Ok I sent you a message