So I have been using Z-Suite since 1.3.1. I recently updated from 1.4.1 to 1.6.0. I also updated the Mono Framework to I am running Z-Suite on a Mac Pro with 32 gig of RAM and a fast SSD.

Now each time I launch the Z-Suite app it takes over one minute and twenty five seconds for the program to open. Previous versions took only a few seconds. Is anyone else experiencing this long delay upon launching the application?

Also… Any one else think it’s ODD that Z-Suite does not have a Quit option in the menu? Nor can you quit the application by hitting command Q. The only way I can quit Z-Suite is clicking on the red dot in the corner of the window. Which is not the normal method for quitting an application on Mac-OS.

I am experiencing exactly the same … but if i launch it a second time (after the initial launch) it starts much more faster …

Right… That’s the typical behavior of previous installations. When you first install Z-Suite the Mono framework takes a while to set up the application & run it.

The new problem I have is that it takes a LONG time each and every time I run it. (No matter how many times I run the app.)

I have found similar issues with Z-suite taking a long time to load, I have not timed it but it loads in a similar time to you… 2013 MacBook Pro 16gb ram with SSD.

They have definitly broken something.

I sure wish someone from Zortrax would comment…

Does anyone know if my older Mac desktop running OS 10.7.5 will work with Z-Suite and the latest Mono??

Im looking to purchase a Zortrax soon and need to know

Just upgraded from V1.5.1 to (I had reverted to V1.5 after trying out V1.6.0). Still, every time I start Z-Suite on my 8-core Mac Pro (16 GB RAM, El Capitan 10.11.5) the icon bounces for 1min and 45sec before the program finally opens. Judging by posts here and elsewhere I’m not the only Mac user experiencing this. Is it because the Mac version runs in Mono? If so, why did previous versions do this the first time I started the program but normally after that while this one does it every time? Anyone know if there is a fix in the works?

Once I got Z-Suite running I sliced a half dozen .stl files with and without inserting pauses and it seemed to work fine. I haven’t printed any of them yet - my “print lab” (4th bedroom) is too hot here in NJ. Anything I need to watch for?

My Zortrax prints exceptionally well and except for the crappy software it’s a pleasure to use. That said, I’m getting tired of Z-Suite so I just ordered a Prusa Orig i3 Mk2 with the intention of keeping one of them, selling the other. Wish me luck.

Johnic: I haven’t done specifically what you asked because I was already running 10.9 (Mavericks) on my aging Mac Pro when I bought a Zortrax M200. However, I did successfully run Z-Suite versions 1.3, 1.4 and 1.5 on 10.9 (Mavericks). When I upgraded to OS 10.10 (Yosemite) then 10.11 (El Capitan), Z-Suite V1.5 continued to run the same as it had - well but with excruciatingly slow slicing on even moderately complex models - 15 to 30 minutes in some cases.

Two important things:

1. You said “the latest Mono.” DO NOT DO THAT. You must install MonoFramework-MDK- and ONLY that version. Please don’t ask me how I know this but Z-Suite will not run on later versions of Mono (the latest release is

2. Once installed, the Z-Suite versions I tried up thru V1.5 booted v-e-r-y slowly the first time but if I waited long enough they did start. The good news is, after that they boot in a few seconds like any other program. Unfortunately, so far V1.6 boots slowly every time I start it. On my 2008 8-core Mac Pro that’s 1-3/4 minutes.

Since it’s easy to install Z-Suite and easy to do a clean uninstall using any app cleaner, there’s little risk so give it a try.

BTW, you should find upgrades from your current 10.7 (Lion) to 10.8 (Mountain Lion) and 10.9 (Mavericks) pretty painless. The big jump in system requirements and program compatibility came with 10.10 (Yosemite). Despite my Mac Pro’s age it seems to run as well or better on 10.10 (Yosemite) and 10.11 (El Capitan). That said, “upgrading” my 2009 MacBook Pro to 10.10 (Yosemite) brought it to an absolute crawl. It took a few days but I finally restored 10.9 (Mavericks) and there it shall stay.

Good luck.

I specifically followed Zortrax’s recommendation that said it needed MDK- That is the version I am running. It still takes one minute and 45 seconds to launch the program each time. Previous versions did not take this long. (Except for the initial installation run.) My machine is running El Capitan 10.11.6

It is my belief that Zortrax broke something in 1.6.0 and they need to fix it.

BTW, Z-Suite runs in the Mono environment on the Mac. Mono is an open-source Unix version of Microsoft’s .NET (dot-net) development platform that supports the development and deployment of cross-platform .NET applications.

.NET was developed by Microsoft; Mono means “monkey” in Spanish. Just sayin’.

I have an update. I saw that Zortrax released a new version 1.6.11. I have downloaded and installed 1.6.11 with Mono Framework I am still seeing a launch time of One Minute and Thirty Seconds. My 2011 Mac Pro is running El Capitan 10.11.6.

It’s still very slow to launch Z-Suite.

Wow. Awesome info!! I’ll be sure to follow your instructions to the tee.

Super stoked to get my printer next week !


I also noticed the same problems you have. Seems like they have a problem with their software on IOS since they launched. What I could see through their updates is that there are slight improvements every version. Hopefully they will address this issue in the next update! I do not know of any fix for this at the moment. Sorry!