Avatar IV (QiDi Tech)

qidi-tech

#1

HI all

Has anyone used qidi 3d printer ?

Any feedback ?

Thank you in advance


#2

Hi I use the Qidi printer and it performs quite well. A bit of a learning curve when you get it but after some playing around with it there are no complaints.


#3

Nice! Thanks for the input @sculptprint! Since there’s not much happening in the Qidi Tech community, would you be willing to share your experiences on 3D printing on a Qidi printer? Feel free to start a new thread where you can share your Marvin, for example. Let me know.


#4

I have the latest QIDI Tech Avatar as well (dual extruder and full metal frame). Out of the box, the prints are just reasonable, but they become outstanding once you take the plunge to upgrade the firmware to Sailfish. It can be a bit of tricky process though…


#5

How did you manage to update the machine firmware? I have been trying for ages with no luck. Thank you


#6

Hey Shamez,

It can be a very frustrating process, but I finally managed to get it upgraded to Sailfish 7.1. Everything later than 7.1 is still giving me trouble, although I would love to try the newer versions! Perhaps we can work together and get it beat. But regardless, the older Sailfish is still way better than the stock firmware.

I started with this tutorial, and even had a couple of my questions answered by Jared himself that helped steer me in the right direction. BTW, the CTC is an pretty much identical to the QIDI but with a wooden frame.

What finally worked for me, was to use ReplicatorG pointing to the Jetty firmware URL, using the machine type Replicator 2X, the board type of Makerbot Replicator 1 Single & Dual, and the firmware Sailfish 7.1 (r895). When you try uploading it, make sure to press the Upload button in RepG at the exact same time that you press the reset button on the QIDI. Also, I removed the white cable to the build platform, since loading the wrong firmware causes the bed heater to turn on and ramp up the temperature as high as possible.

Let me know how you get on with 7.1, and I’ll try and answer any specific questions you have while doing it. After that, we can try and get the higher versions to work. I attached a couple of images showing the firmware version, as well as my custom machine name in the main menu. :slight_smile:

Adam


#7

Thanks Adam Sounds like a plan :slight_smile: Shamez


#8

Hey Adam I managed to get version 7.5 firmware uploaded by using board version replicator 2x. Let me know if that works for you as well. Thank you Shamez


#9

Shamez,

I just tried doing 7.5 again (several times), but it always fails for me. Do you remember all the steps and settings you used? I really want to get past 7.1. At least the good news is that I now know it is definitely possible if you were able to do it!

Adam


#10

Adam The only different thing I did was use replicator G saltfish version. I tried several times and found clicking the upload button 2 sec before the reset button worked. Another thing I noticed, my printer was on version 7.2 to begin with. Maybe an update to 7.2 prior to 7.5 will do the trick. Let me know if I can help with anything Shamez


#11

Using Makerbot Desktop, I was able to step through their firmware from 7.2, 7.3, 7.4, 7.5 in order. But I still can’t get it to accept Sailfish 7.5. Are you absolutely sure you have Sailfish 7.5 and not just the Makerbot 7.5? If you go into the version info on your LCD screen, does it say Replicator or Sailfish?

Adam


#12

Ah! I’m sorry, you might be right. It just says firmware 7.5 does not say sailfish


#13

That’s too bad, but at least it means I’m not going crazy! :slight_smile:

I’m not sure of the differences between the proper Sailfish 7.1 and the Makerbot 7.5 (or which one is better), but there has to be a way to get the later Sailfish versions on this bot. I’m not giving up on it…


#14

Same here I will keep at it and if I make any progress I will let you know


#15

Hi, Thanks for the info. I have a QiDi Tech 1 metalframe and I was also able to upgrade to SF 7.1 using your settings but now it seems my SD card will no longer work. Have you run into this? (I see that QiDi has come out with a new version printer that comes with SF 7.8, on their eBay store).

Thanks,

Bill


#16

Hi Bill,

Yes, the SD card will not work after upgrading to SF 7.1, unless you reformat it to regular FAT (not FAT-32). I think it also has to be 2GB or less. This will get it working for you again, although it also limits you to a 30 character file name.

That’s interesting about the new ones coming with SF 7.8. And unless they also upgraded to a board with the Atmega 2560, then there’s a good chance it’s exactly the same as ours. Not to mention that the linked You Tube video works on a CTC that also has the exact same board as ours, so I’m sure we should be able to do it as well. Just need to get the right procedure nailed down, as well as the timing. If you’re willing to keep trying and update us with any progress, then at least there is 3 of us working on it! :slight_smile:

Adam


#17

Adam,

Many thanks, I will give that a try. I know the card is FAT-32. I will scrounge up an old one and try again.

The ebay ad does say the controller is now a Atmega 2560. I am planning on trying to get some information out of the QiDi Tech company… I know, good luck. If I get any info I will certainly post it.

Bill


#18

Has anyone made any progress on getting the firmware past Sailfish 7.1? I’m curious to see what this machine can do with the latest improvements, especially in terms of speed. I feel limited to 40mm/s at the moment. Anything faster than that, and the machine has difficulty maintaining the quality of the print.


#19

I’ve had no luck. I made several attempts.


#20

Hi Adam,

Are there any instructions on reloading the original firmware? I don’t even know the version (Creator 1?).

The board itself looks pretty much like a MightyBoard Rev E with the Atmega1280 and mega8u…

This website appears to to provide the original firmware but does not reload it thru the boot loader but via the ISP port:

http://www.unclechucks3dprinterstuff.com/firmware%20restore.htm

Any info would be appreciated. Thanks,

Bill